Home » RDBMS Server » Enterprise Manager » Tough OMS Problem
Tough OMS Problem [message #136346] Wed, 07 September 2005 12:11 Go to next message
jlrosenlof
Messages: 3
Registered: September 2005
Junior Member
Hi,

I'm a huge n00b when it comes to Oracle. I've googled all over the place and tried searching this problem on Oracles site, but I can't seem to find an answer to this. Hopefully someone can help me out with this.

I got our OEM set up and everything was running correctly for a few weeks. One day I needed to restart the OEM and as I exited, it froze the computer. After I restarted, I have not been able to start up the OMS. Here are the error messages that I'm getting:

When I try to start the management server process it fails and the following error messages are found in the Application Event Log--

-The service is entering into production run mode.
-The process termination failed for JRE. %2
-The service has terminated abnormally. See the file *\*\*\oms.nohup for details.

When I look in the oms.nohup file, here is what it tells me:

Error starting Oracle Management Server. VXA-2020 : Error encountered when service [vdp] attempted to export its servicesOEMCTRL for Windows NT: Version 2.2.0.0.0
Copyright (c) 1998, 2000, Oracle Corporation. All rights reserved.
Starting the Oracle Management Server... [main][2005-7-6:12:9:39:46] VdbSession.processError: errorCode >1033<
[main][2005-7-6:12:9:39:46] VdbSession.processError: errorMsg >ORA-01033: ORACLE initialization or shutdown in progress
<
[main][2005-7-6:12:9:39:46] VdbSession.processError: database connection error
[main][2005-7-6:12:9:49:250] VdbSession.processError: errorCode >1033<
[main][2005-7-6:12:9:49:250] VdbSession.processError: errorMsg >ORA-01033: ORACLE initialization or shutdown in progress
<
[main][2005-7-6:12:9:49:250] VdbSession.processError: database connection error
VXA-3008 : Starting OMS Services, Wait.

[main][2005-7-6:12:10:45:93] VDP PANIC: SQL exception caught inside VdpPingServiceImpl.redistributeNodesOnStartUp()
exception VdbSQLException{wstring reason="ORA-06553: PLS-213: package STANDARD not accessible\n";long oracleError=6553;long errorCode=3;wstring sqlStmt="";}
at oracle.sysman.vdb.VdbStatement.processError(VdbStatement.java:368)
at oracle.sysman.vdb.VdbCallableStatement.execute(VdbCallableStatement.java:223)
at oracle.sysman.vdb.VdbAutoCommitSession.executeQuery(VdbAutoCommitSession.java:336)
at oracle.sysman.vdp.VdpPingServiceImpl.redistributeNodesOnStartUp(VdpPingServiceImpl.java:541)
at oracle.sysman.vdp.VdpPingServiceImpl.exportServices(VdpPingServiceImpl.java:324)
at oracle.sysman.vxa.VxaAppServer.startServices(VxaAppServer.java:1513)
at oracle.sysman.vxa.VxaAppServer.main(VxaAppServer.java:2547)
[main][2005-7-6:12:10:45:734] VD-5251 : A system error has occurred inside [Pinging Service]: ORA-06553: PLS-213: package STANDARD not accessible

[main][2005-7-6:12:10:45:734] VXA-2021 :
OMS Service startup failed!
oracle.sysman.vxn.VxnBootstrapException: VXA-2020 : Error encountered when service [vdp] attempted to export its services
at oracle.sysman.vxa.VxaAppServer.startServices(VxaAppServer.java:1514)
at oracle.sysman.vxa.VxaAppServer.main(VxaAppServer.java:2547)

Error starting Oracle Management Server. VXA-2020 : Error encountered when service [vdp] attempted to export its services.

I'm pretty lost here. I'd really appreciate any help that anyone could give me.

Thanks,
John
Re: Tough OMS Problem [message #136349 is a reply to message #136346] Wed, 07 September 2005 12:23 Go to previous message
Mahesh Rajendran
Messages: 10697
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Seems OMS is not happy with the database componenets.
May be repository database is not available.
Do a clean shutdown of all the services/database.
REboot the machine.
mount and open only the database that has the repository / oms compoenents.
see whether you can establish a simple sql connection into this.
Post the errors.
>> ORA-06553: PLS-213: package STANDARD not accessible
Try to compile the package SYS.STANDARD.
If that does not work,
then run $ORACLE_HOME/rdbms/admin/catalog.sql and catproc.sql logged in as SYS.
Try again.
Make sure you have
1. all databases in all pariticipating nodes are avaible.
2. their listeners are avaiable.
3. their intelligent agents are available.
4. You can individually to a simple sql session.
5. Start OMS.
Previous Topic: Connect to 10g OEM with Windows o/s authentication?
Next Topic: ORA-27101: Shared memory realm does not exist
Goto Forum:
  


Current Time: Fri May 20 15:32:30 CDT 2022