Home » RDBMS Server » Enterprise Manager » database status unavailable--configuration issue
database status unavailable--configuration issue [message #121370] Fri, 27 May 2005 16:11 Go to next message
nyphot
Messages: 2
Registered: May 2005
Junior Member
I've been having a really tough time getting Enterprise Manager to work in 10g. I can get it to the hostname:5500/em screen at long last, but it says "The database status is currently unavailable. It is possible that the database is in mount or nomount state..." If I hit Startup from that page, I can successfully shutdown or startup the database from that page. If I try to Perform Recovery, I'm told "Unable to connect to the database. Io exception: The Network Adapter could not establish the connection."

It's clearly connecting to some degree because I CAN startup and shutdown the database from this login. But clearly not enough because I can't actually access the database and there's that Network Adapter error...

What am I doing wrong?

I've been configuring Enterprise Manager using emca... Here's the output of the command.

[oracle.oinstall@jon-oracle bin]$ ./emca -r

STARTED EMCA at Fri May 27 12:47:36 EDT 2005
Enter the following information about the database to be configured
Listener port number: 1521
Database SID: oraclej
Service name: oraclej
Email address for notification:
Email gateway for notification:
Password for dbsnmp:
Password for sysman:
Password for sys:

-----------------------------------------------------------------

You have specified the following settings

Database ORACLE_HOME ................ /u01/app/oracle/product/10.1.0/db_1
Enterprise Manager ORACLE_HOME ................ /u01/app/oracle/product/10.1.0/db_1

Database host name ................ jon-oracle.oho.com
Listener port number ................ 1521
Database SID ................ oraclej
Service name ................ oraclej
Email address for notification ...............
Email gateway for notification ...............

-----------------------------------------------------------------
Do you wish to continue? [yes/no]: yes
May 27, 2005 12:47:49 PM oracle.sysman.emcp.EMConfig updateReposVars
INFO: Updating file /u01/app/oracle/product/10.1.0/db_1/sysman/emdrep/config/repository.variables ...
May 27, 2005 12:47:51 PM oracle.sysman.emcp.EMConfig addPortEntries
INFO: Updating file /u01/app/oracle/product/10.1.0/db_1/install/portlist.ini ...May 27, 2005 12:47:51 PM oracle.sysman.emcp.EMConfig updateEmdProps
INFO: Updating file /u01/app/oracle/product/10.1.0/db_1/sysman/config/emd.properties ...
May 27, 2005 12:47:52 PM oracle.sysman.emcp.EMConfig updateConfigFiles
INFO: targets.xml file is updated successfully
May 27, 2005 12:47:52 PM oracle.sysman.emcp.EMConfig updateEmomsProps
INFO: Updating file /u01/app/oracle/product/10.1.0/db_1/sysman/config/emoms.properties ...
May 27, 2005 12:47:52 PM oracle.sysman.emcp.EMConfig updateConfigFiles
INFO: emoms.properties file is updated successfully
May 27, 2005 12:47:59 PM oracle.sysman.emcp.EMConfig startOMS
INFO: Starting the DBConsole ...
May 27, 2005 12:49:43 PM oracle.sysman.emcp.EMConfig perform
INFO: DBConsole is started successfully
May 27, 2005 12:49:43 PM oracle.sysman.emcp.EMConfig perform
INFO: >>>>>>>>>>> The Enterprise Manager URL is http://jon-oracle.oho.com:5500/em <<<<<<<<<<<
Enterprise Manager configuration is completed successfully
FINISHED EMCA at Fri May 27 12:49:43 EDT 2005
Re: database status unavailable--configuration issue [message #126349 is a reply to message #121370] Mon, 04 July 2005 00:24 Go to previous messageGo to next message
Achchan
Messages: 86
Registered: June 2005
Member
If you are on windows: Go to Control Panel-->Administrative Tools-->Local Security Policy-->Local Policies-->User Rights Assignment-->U will see in the policy as "Log on as a batch Job-->right click-->Properties-->add user or groups-->give your OS username.
I think this will solve the problem and also use your hostname instead of localhost in your URL.
Note that database control is a really BUGGY tool amont all Oracle products.Try to use EM Client or Instant Client if you are on a remote machine.
Re: database status unavailable--configuration issue [message #126641 is a reply to message #126349] Wed, 06 July 2005 01:27 Go to previous messageGo to next message
Frank Naude
Messages: 4571
Registered: April 1998
Senior Member
Hi,

Another solution migh be to reconfigure EM sing the "emca -r" command (Enterprise Manager Configuration Assistant).

The "-r" option is important as it skips creation of repository schema objects. Do a "dbca -?" to see all available command line options.

Best regards.

Frank
Re: database status unavailable--configuration issue [message #126748 is a reply to message #126641] Wed, 06 July 2005 08:11 Go to previous message
nyphot
Messages: 2
Registered: May 2005
Junior Member
Thanks for your advice.

Alas, I am using Linux so the Windows hint doesn't help. And I have been using emca -r... In fact that's what I'm having trouble with!

One workaround that I've used is just running dbca after I've created the DB. That somehow runs emca internally with the correct parameters.

Still... frustrating. I was trying to get away from all X windows in the installer because they're SO slow.
Previous Topic: Problem with Database Control?
Next Topic: VNI-4048
Goto Forum:
  


Current Time: Tue May 24 01:02:50 CDT 2022