Home » RDBMS Server » Enterprise Manager » oracle agent
oracle agent [message #68269] Fri, 28 February 2003 02:57 Go to next message
wangsanjun
Messages: 13
Registered: June 2002
Junior Member
Here is two host a1 and a2.we use hacmp to take over (auto) where one host crashs
bettween a1 and a2,so we setup the same database pa1 and a2 as the following:
a.we setup database on a1 successfully(lsnrctl,agent,database ok)
b.copy the all oracle files of a1 to a2.
c.the main oracle data file and control file are shared(on the tape).
d.some changes we made to adjust to a2(listener.ora,tnsname.ora host-->a2 host IP)
Now occurs the following:
a.database and lsnrctl is ok .
b.when we start the intelligent agent service,there occurs error(agent failed) as the
following:
============================================================================
DBSNMP for AIX 5.1: release 9.2.0.0.0 - Production on 20-FEB-03 05:24:16
Discovering services on s901 configured on host addresses {s901 10.2.101.3}
Using oratab file /etc/oratab
Warning : Error while sourcing third party discovery file emddiscover.tcl : can'
t read "tabfile": no such variable
============================================================================
c.when we rename hostname a2 to a1.the agent now is ok.
How can we do? with the different hostname.
Some advice we prefer.thanks.
Re: oracle agent [message #68272 is a reply to message #68269] Fri, 28 February 2003 06:45 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10697
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
1. Edit the $ORACLE_HOMEnetworkagentconfignmiconf.lst file and remove the line that calls the emddiscover.tcl script. 

2. Restart the Agent.

Re: oracle agent [message #68277 is a reply to message #68269] Mon, 03 March 2003 03:52 Go to previous messageGo to next message
wangsanjun
Messages: 13
Registered: June 2002
Junior Member
agent still can not start.error info as the following:
nmiclbg_ensureAlive:: Initialize error for nmigenctx
Re: oracle agent [message #68483 is a reply to message #68277] Tue, 11 November 2003 02:17 Go to previous message
Christoph Heine
Messages: 1
Registered: November 2003
Junior Member
I received this error massage after I have deleted tnsnames.ora, listener.ora and sqlnet.ora. Then I could not start the agent. So I just undeleted all three files and the agent works fine.
Previous Topic: Passing parameter to OEM from OWB.
Next Topic: Listener error
Goto Forum:
  


Current Time: Wed May 18 14:42:41 CDT 2022