Home » RDBMS Server » Enterprise Manager » Oracle Intelligent Agent fails
Oracle Intelligent Agent fails [message #67954] Wed, 31 July 2002 05:50 Go to next message
Cristobal
Messages: 5
Registered: July 2002
Junior Member
Hi all,

I'm configuring an OEM managing several Oracle servers (8.1.6 under Solaris). Everything is working properly with almost all servers but I get an error in some of them :

[[oracle@carcharedon oracle]]$ lsnrctl dbsnmp_start
LSNRCTL for Solaris: Version 8.1.6.2.0 - Production on 31-JUL-2002 15:24:32
(c) Copyright 1998, 1999, Oracle Corporation. All rights reserved.
[[oracle@carcharedon oracle]]$

Immediately after start I get the following error via stderr :
Tcl_RegisterChannel: duplicate channel names

In those server working fine I can found two processes running :

[[oracle@med2 oracle]]$ ps -ef &#124grep dbsnmp
oracle 3244 1 2 15:28:38 ? 0:00 dbsnmp
oracle 3284 3244 1 15:28:39 ? 0:00 dbsnmp

While in the servers with that issue only one process stay running. When only one process stay running you can see that the OEM server discovers the node correctly but the jobs submitted to it are never started.

Any idea about that issue ?

Thanks in advance
Re: Oracle Intelligent Agent fails [message #67965 is a reply to message #67954] Tue, 06 August 2002 03:43 Go to previous message
Cristobal
Messages: 5
Registered: July 2002
Junior Member
Hi people,

I just solved the problem by erasing the following fucking file :
/home/oracle/product/8.1.6/network/agent/library/pkgIndex.tcl

The idea is erase that file just before run "lsnrctl dbsnmp_start". Then both processes starts without trouble. I suppose that upgrading my 8.1.6 oracle intelligent agent i would solved the problem also.

Have fun ... but not so much ;-)
Previous Topic: loader problem 2
Next Topic: Install Management server
Goto Forum:
  


Current Time: Sat May 21 14:30:42 CDT 2022