Home » RDBMS Server » Enterprise Manager » IA discovery
IA discovery [message #67882] Sun, 23 June 2002 21:54 Go to next message
John Carroll
Messages: 3
Registered: February 2002
Junior Member
I am trying to make the OEM discover an intelligemnt agent I have set running. On discovery I get the message "Discovery Failed:VNI-4026:Discovery Failed:Error while transferring services.ora from agent:4009" I have made the IA work on other machines. I am running Oracle 8.1.7 on Solaris. The OEM is 901 but this is not the problem as I have the same combination working on a different machine. while fault finding it transpired that the agent does not return a tnsping on 1754, 1748 is working correctly in the same way as on other boxes I have. I have tried deleteing all my *.q files and the services.ora, snmp_ro.ora, snmp_rw.ora but this made no difference. Any help would be appreciated.

John
Re: IA discovery [message #67883 is a reply to message #67882] Mon, 24 June 2002 03:20 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10697
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
1. did you ,Check the permissions on the services.ora file.  

   $ ls -l $ORACLE_HOME/network/agent/services.ora

You might see something like this:

   -rw-rw----   1 oracle dba  

2.  Verify the Intelligent Agent process is started by the Oracle 
(or equivalent DBA user).  If the Agent is started by a non DBA user, the user 
may not have permissions to read the services.ora file.

3.  Stop the Intelligent Agent
4.  Logon as Oracle or equivalent DBA user
5.  Remove the services.ora file  (The file will be recreated automatically when
    the agent is restarted.)
6.  Start the Intelligent Agent

7. if the above procedure doesnt work, then
   either
	Relink the agent executables as the Oracle user: 

	$ lsnrctl dbsnmp_stop 
	$ cd $ORACLE_HOME/network/lib 
	$ make -f ins_oemagent.mk install 
	$ lsnrctl dbsnmp_start 
   or
	Multiple Intelligent Agents may be installed on the system and the wrong Agent
	is running.
Re: IA discovery [message #67886 is a reply to message #67882] Mon, 24 June 2002 19:58 Go to previous message
John Carroll
Messages: 3
Registered: February 2002
Junior Member
Thanks for that,
I tried your suggestion and it did not help. When trying to run dbsnmp_start as the Oracle user it fails to start-up properly and I get the error message "NMS-00308: Failed to listen on address: another agent may be running " in the log file, this is not correct as there is no other dbsnmp processes running. I get this message no matter what state the services.ora file is in (owned by oracle, owned by root, removed fully, chmod 777). If I try to start the process as root it starts up and keeps running however in the OEM console when I try to discover the node I get the message vni 4026 cannot transfer services.ora again I have tried all permutations of permissions for this file. I cannot tnsping port 1754 but I do get a response from 1748 which I find interesting. We have the exact same problem on 2 servers both running Oracle 8.1.7

Regards
John
Previous Topic: VNI-2015
Next Topic: Oracle 8i installation problems.
Goto Forum:
  


Current Time: Mon May 16 16:51:09 CDT 2022