Home » Infrastructure » Windows » Windows service starts but database doesn't (Windows XP SP2, Oracle 10gR2 Express)
icon8.gif  Windows service starts but database doesn't [message #320281] Wed, 14 May 2008 09:03 Go to next message
Messages: 1
Registered: May 2008
Junior Member
Hello guys,

I have read so many forums and tutorials, I'm lost. You are my last hope!

I have an Oracle 10g R2 Express database running on a Windows XP SP2 machine, and I always have to startup the database manually.

My services OracleServiceXE and OracleTNSListener are set to Automatic, the registry values seem correct (ORA_XE_AUTOSTART is set to TRUE), the SPFILE path has been verified.

Once the OracleServiceXE service is started, I have to startup the database manually (SQL> startup), and I don't have any error, everything is fine.


Any help would be really appreciated.

Edit: I also tried to recreate the service using Oradim. No luck.

[Updated on: Wed, 14 May 2008 09:09]

Report message to a moderator

Re: Windows service starts but database doesn't [message #320334 is a reply to message #320281] Wed, 14 May 2008 13:49 Go to previous message
Barbara Boehmer
Messages: 8922
Registered: November 2002
Location: California, USA
Senior Member
I used to have a similar setup, running Oracle Express Edition on Windows XP Home Edition Service Pack 2, with the service and listener set to automatic. What I found is if there are a whole bunch of things set to start automatic, and hogging limited memory, then it is likely to fail. When I set everything else to manual and made it so that Oracle was the only thing starting automatically, then it worked fine. Windows also seems to sometimes have problems doing things out of sequence, so it can't start the service, because the listener isn't started yet. You may be better off settling for just starting the listener automatically and starting the database manually. If you have more than one Oracle database, that can also complicate things. I had 9i Enterprise Edition and 10g Express Edition running on the same machine. That works if you have them both using the 10g listener and disable the 9i listener. I could use both databases at once, if I started one automatically, then the other manually. The good news is that I can run 11g Enterprise Edition on Windows Vista Home Basic on a machine with a lot more RAM (2 GB) and have it start automatically. I don't know whether it is the newer version of the operating system, or the newer version of Oracle or more ram that makes the difference, but I have not had any problems with the new setup.
Previous Topic: Unable to run Oracle Application devoped in 10g on windows vista
Next Topic: Oracle 10g datbase 64bit on windows2003 server x-64
Goto Forum:

Current Time: Fri May 20 16:02:11 CDT 2022